SOLVED: My 2003 crown victoria p71 pings on accelleration.

Detail: My 2003 crown victoria p71 pings on accelleration. 2 weeks ago, the entire egr system was cleaned professionally - twice, still pings. Last week a professional Crown Victoria mechanic (works for a police dept) replaced MAF sensor, still pings. New plugs and boots last month. EGR and MAF readings on his computer (mobile device which reads at various speeds - he rode along with me and took readings) read within proper specs at all speeds. I am using regular grade 87 octane fuel, which is what the cops all use. 114K on car. Any suggestions?
Detail Question SOLVED: My 2003 crown victoria p71 pings on accelleration.

Solution: Check the timing. It may be off slightly. I would up the octane on an engine that big too. , Hi, a 6ya Mechanic can help you resolve that issue over the phone in a minute or two. Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US. click here to Talk to a Mechanic (only for users in the US for now) and get all the help you need. Goodluck! , Yes they are as long as the Motors are Similar. , Accessory Drive Component Locations , there are 5+ pages of fuses what specifically do you need

Latest Searches

By entering you agreed with our Terms of use and Privacy Policy.If you do not agree, please do not use this service or you will face consequences.
This site powered by Express JS, node.js, MongoDBand advanced javascript algorithm include all npm modules
Copyrighted © 2015