SOLVED: When my 1990 subaru legacy is cold it runs good

Detail: It does not run hot but after traveling 5 or 10 miles it cuts back starts skipping and a strong smell of gas comes in car. also engine light comes on and if i push down on accellerator black smoke comes out of exaust why?
Detail Question SOLVED: When my 1990 subaru legacy is cold it runs good

Solution: Could be a faulty O2 sensor. The sensor would not take action until the engine warmed up. Have you checked for trouble codes in the engine computer ? , Hi, a 6ya Mechanic can help you resolve that issue over the phone in a minute or two. Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US. click here to Talk to a Mechanic (only for users in the US for now) and get all the help you need. Goodluck! , make sure you bleed the air out of the system on the top left hand side of the radiator or the car will overheat due to air lock , Check The Vehicle Speed Sensors. The Legacy has 2 Vehicle Speed Sensors (VSS): VSS1 is located inside of the transaxle; VSS2 is located in the combination meter assembly. VSS1 Disconnect the electrical harness from the transaxle. Connect an ohmmeter across the transaxle's electrical harness terminals 9 and 16. The resistance should be 450-650 ohms. After testing, reconnect the electrical harness.VSS2 Remove the instrument cluster from the instrument panel. Disconnect the electrical connectors and the speedometer cable from the instrument cluster. Connect an ohmmeter or continuity tester across the combination meter terminals 7 and 11. Insert a small screwdriver in the speedometer cable drive socket. Rotate the speedometer drive and note the continuity across the VSS terminal. Continuity should turn ON/OFF 4 times per speedometer drive revolution. , I hate to tell you this but the guy isn't returning your calls because the head gasket is blown and he probably knew it. As for the 1990... have you checked the water pump for leaks? (front/ driver's side on the bottom of the engine) My guess is that it's faulty and unfortunately, it's behind the timing belt. Both of these repairs will be a pretty penny. Good luck! , there is a recall on some of the fuel lines under the hood, they get old and leak. , Please have your exaust pipes checked, perhaps a mount is burning. The catalytic converter can make a nasty odor when it is clogged. Check the wear on the serpintine belt.

Latest Searches

By entering you agreed with our Terms of use and Privacy Policy.If you do not agree, please do not use this service or you will face consequences.
This site powered by Express JS, node.js, MongoDBand advanced javascript algorithm include all npm modules
Copyrighted © 2015