SOLVED: 1997 Subaru GTB wagon

Detail: My GTB every now and then has problems starting, i notice that a couple of times it has fired up on ignition slowy, but has started, but once it has done nothing!! the dash lights and everything was fine, it just didnt turn over! i managed to push start it, ad once home i turned it off, and tried to start it, and it went, could the coils be shot??
Detail Question SOLVED: 1997 Subaru GTB wagon

Solution: Fix your car right away, by clicking the link 1997 Subaru , Hi, a 6ya Mechanic can help you resolve that issue over the phone in a minute or two. Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US. click here to Talk to a Mechanic (only for users in the US for now) and get all the help you need. Goodluck! , Welllllllllll how do I say this without incriminating myself too much, after furiously mad panic stations on the sunday, it was decided that first thing monday it would be towed to the electricians! as my husband had concluded it was electrical this came after new battery fuses etc.. had been checked and many an hour spent under the bonnet.As we have a kill switch, which I had tried an still did not go also I reminded my husband of this and he screamed at me its not the bloody kill switch @#!*!!? ok, have a GREAT DAY! So come monday morning after getting up early to drop my husband off at work dressed only in my dressing gown jammies and socks and slippers I duly dropped him off and used our pajero for the day which I ended up having to put 10 dollars in. That night he returned home with the subaru and a receipt for work done I ( I had visions of hundreds of dollars worth) but noooooo $54.00 great ah! Cos it was the kill switch !!!!. We will never speak of this again!!!!! It is often the simple things in life that we overlook? TeeHeeee. Linda , the alarm turned off as soon as you unlock the door with the key... the clicking noise could just be the fact that your battery is dead. hope i was some help , i believe so since axles are pretty much a standard platform for the same vehicles . the only time stud patterns are different is when it's different manufacturers. please rate this , I have the same problem with my 86 GL 4WD. One day it started to turn, and then lost all power. I couldn't even turn on the lights. I have played with the ignition switch wires, and gotten it to fire. I think there may be a short somewhere in the switch or the wires to the harness, but I have not isolated it yet. You might check your ignition switch and wiring... , Please have the computer scanned for codes. Autozone or Pepboys will do it task for free. It sounds like it could be related to your fuel sustem or exhaust. But I need more info to be more spesific. Good luck.

Latest Searches

By entering you agreed with our Terms of use and Privacy Policy.If you do not agree, please do not use this service or you will face consequences.
This site powered by Express JS, node.js, MongoDBand advanced javascript algorithm include all npm modules
Copyrighted © 2015